Numeric Errors Affecting ffmpeg Open this link in a new tab package, versions >=2.2, <2.8.3


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEG-470719

  • published

    2 Oct 2019

  • disclosed

    17 Dec 2014

  • credit

    Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Numeric Errors because it doesn't ensure that pre-established digits and word array dimensions satisfy a required mathematical relationship. This flaw allows attacks to use X-Face image data to cause out-of-bounds array access and ultimately a denial of service.