Out-of-bounds Read Affecting ffmpeg package, versions >=2.2, <2.8.3


0.0
high

Snyk CVSS

    Attack Complexity Low
NVD  high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-FFMPEG-470766
  • published 2 Oct 2019
  • disclosed 9 May 2015
  • credit Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Out-of-bounds Read. A malicious user can pass a malicious LucasArts Smush file to the system to cause a segmentation violation.