Use After Free Affecting ffmpeg package, versions >=2.2, <2.8.3


0.0
high

Snyk CVSS

    Attack Complexity Low
NVD  high
RHEL  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-FFMPEG-470772
  • published 2 Oct 2019
  • disclosed 7 Nov 2014
  • credit Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Use After Free via the matroska_read_seek function in matroskadec.c.