Out-of-Bounds Affecting ffmpeg package, versions >=2.2, <2.8.3


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-FFMPEG-470851
  • published 2 Oct 2019
  • disclosed 8 May 2017
  • credit Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Out-of-Bounds. FFmpeg is vulnerable to denial of service (DoS) attacks and possibly other attacks. The library does not ensure that the pix_fmt parameter is set, allowing a malicious user to cause the application to crash by passing a file to the system.