Out-of-Bounds Affecting ffmpeg package, versions >=2.2, <2.8.3


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEG-470861

  • published

    2 Oct 2019

  • disclosed

    12 Feb 2016

  • credit

    Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Out-of-Bounds. FFmpeg is vulnerable to denial of service (DoS) attacks. A malicious user can pass a malicious TIFF file to the system, causing an out-of-bounds read that can crash the system.