Out-of-bounds Read Affecting ffmpeg package, versions >=0.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-FFMPEG-470897
  • published 2 Oct 2019
  • disclosed 23 Dec 2016
  • credit Unknown

How to fix?

There is no fixed version for FFmpeg.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Out-of-bounds Read. FFmpeg is vulnerable to information disclosure. The library reads out-of-bounds memory read when decoding with cavs_decode.