Out-of-Bounds Affecting ffmpeg Open this link in a new tab package, versions >=2.2, <2.8.3


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEG-470902

  • published

    2 Oct 2019

  • disclosed

    16 Jun 2015

  • credit

    Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Out-of-Bounds. FFmpeg is vulnerable to denial of service (DoS) attacks and possibly other attacks. A malicious user can pass a malicious rle image file to the system that can cause an out-of-bounds array access that can cause the system to crash.