Out-of-bounds Read Affecting ffmpeg package, versions >=2.8.3


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Availability High
Expand this section
SUSE
5.3 medium
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-FFMPEG-470925
  • published 2 Oct 2019
  • disclosed 29 Jun 2018
  • credit Unknown

How to fix?

There is no fixed version for FFmpeg.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Out-of-bounds Read. FFmpeg is vulnerable to denial of service (DoS). The attack exists because it does not validate the mqaunt variable for negative values, allowing the attacker to launch the attack by sending malicious AVI file.

References