Information Exposure Affecting ffmpeg package, versions >=2.2, <2.8.3


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-FFMPEG-470946
  • published 2 Oct 2019
  • disclosed 1 Jun 2017
  • credit Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Information Exposure. FFmpeg is vulnerable to information disclosure. The library does not properly handle HTTP Live Streaming filename extensions and demuxer names. A malicious user can pass playlist files to the system to obtain sensitive information.