Out-of-Bounds Affecting ffmpeg package, versions >=2.2, <2.8.3


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-FFMPEG-471063
  • published 2 Oct 2019
  • disclosed 28 Nov 2014
  • credit Unknown

How to fix?

Upgrade FFmpeg to version 2.8.3 or higher.

Overview

FFmpeg is a FFmpeg static library ruby binding that is compiled for iOS and CocoaPods.

Affected versions of this package are vulnerable to Out-of-Bounds. FFMpeg is vulnerable to denial of service (DoS) attacks. These attacks are possible through the ff_hevc_decode_nal_sps function which allows remote attackers to cause out-of-bounds access through a .bit file.