Out-of-Bounds Affecting ffmpeg-up-to-date Open this link in a new tab package, versions <2.8.3


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEGUPTODATE-470729

  • published

    2 Oct 2019

  • disclosed

    6 Dec 2016

  • credit

    Unknown

How to fix?

Upgrade FFmpeg-up-to-date to version 2.8.3 or higher.

Overview

FFmpeg-up-to-date is a FFmpeg static libraries compiled for iOS

Affected versions of this package are vulnerable to Out-of-Bounds. A heap-based buffer overflow in libavformat/rtmppkt.c is caused by the failure to check for RTMP packet size mismatches. The resulted buffer overflow can be exploited by aligning chunks and by using a white-what-where condition to launch RCE.