Out-of-Bounds Affecting ffmpeg-up-to-date Open this link in a new tab package, versions <2.4.12 >=2.5.0, <2.5.9 >=2.6.0, <2.6.5 >=2.7.0, <2.7.3 >=2.8.0, <2.8.3


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEGUPTODATE-470845

  • published

    2 Oct 2019

  • disclosed

    26 Nov 2015

  • credit

    Unknown

How to fix?

Upgrade FFmpeg-up-to-date to version 2.4.12, 2.5.9, 2.6.5, 2.7.3, 2.8.3 or higher.

Overview

FFmpeg-up-to-date is a FFmpeg static libraries compiled for iOS

Affected versions of this package are vulnerable to Out-of-Bounds. FFmpeg is vulnerable to denial of service (DoS) attacks. A malicious user can pass a malicious jpeg file to the system to cause an out-of-bounds heap-memory access which can cause the system to crash.