Numeric Errors Affecting ffmpeg-up-to-date Open this link in a new tab package, versions <2.4.12 >=2.5.0, <2.5.9 >=2.6.0, <2.6.5 >=2.7.0, <2.7.3 >=2.8.0, <2.8.3


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-FFMPEGUPTODATE-470856

  • published

    2 Oct 2019

  • disclosed

    14 Nov 2015

  • credit

    Unknown

How to fix?

Upgrade FFmpeg-up-to-date to version 2.4.12, 2.5.9, 2.6.5, 2.7.3, 2.8.3 or higher.

Overview

FFmpeg-up-to-date is a FFmpeg static libraries compiled for iOS

Affected versions of this package are vulnerable to Numeric Errors. FFmpeg is vulnerable to denial of service (DoS) attacks. A malicious user can pass an Indeo Video file to the system to cause an integer overflow that can lead to the system crashing.