Information Exposure Affecting gcdwebserver package, versions <3.5.3


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-GCDWEBSERVER-472118

  • published

    9 Oct 2019

  • disclosed

    10 Aug 2019

  • credit

    SiOS-Submission

How to fix?

Upgrade GCDWebServer to version 3.5.3 or higher.

Overview

GCDWebServer is a modern and lightweight GCD based HTTP 1.1 server designed to be embedded in iOS, macOS & tvOS apps.

Affected versions of this package are vulnerable to Information Exposure. An issue was discovered in GCDWebServer before 3.5.3. The method moveItem in the GCDWebUploader class checks the FileExtension of newAbsolutePath but not oldAbsolutePath. By leveraging this vulnerability, an adversary can make an inaccessible file be available (the credential of the app, for instance).