Out-of-bounds Write Affecting grpc package, versions <1.2.0-pre2


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-GRPC-472394
  • published 4 Sep 2019
  • disclosed 30 Apr 2017
  • credit Unknown

How to fix?

Upgrade gRPC to version 1.2.0-pre2 or higher.

Overview

gRPC is a modern, open source, high-performance remote procedure call (RPC) framework that can run anywhere.

Affected versions of this package are vulnerable to Out-of-bounds Write caused by a heap-based use-after-free related to the grpc_call_destroy function in core/lib/surface/call.c.