Improper Input Validation Affecting imagemagick package, versions >=0.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low
Expand this section
RHEL
3.3 low
Expand this section
SUSE
5.3 medium
Expand this section
NVD
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-IMAGEMAGICK-1303396
  • published 11 Jun 2021
  • disclosed 11 Jun 2021
  • credit Suhwan Song

How to fix?

There is no fixed version for ImageMagick.

Overview

ImageMagick is a pod that allows you to convert, edit and compose Images.

Affected versions of this package are vulnerable to Improper Input Validation. In ImageMagick versions before 7.0.9-0, there are outside the range of representable values of type 'float' at MagickCore/quantize.c.

References