Arbitrary File Read Affecting imagemagick package, versions >=0.0.0


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.06% (26th percentile)
Expand this section
NVD
3.6 low
Expand this section
Red Hat
4.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-IMAGEMAGICK-1727336
  • published 1 Oct 2021
  • disclosed 13 Sep 2021
  • credit Unknown

How to fix?

There is no fixed version for ImageMagick.

Overview

ImageMagick is a pod that allows you to convert, edit and compose Images.

Affected versions of this package are vulnerable to Arbitrary File Read. Possible read or write in postscript files is possible. In affected versions and in certain cases, Postscript files could be read and written when specifically excluded by a module policy in policy.xml. ex. .

References