Buffer Overflow Affecting imagemagick package, versions <6.9.12-62 >=7.0.1-0, <7.1.0-47


0.0
high

Snyk CVSS

    Attack Complexity Low
Expand this section
RHEL
5.5 medium
Expand this section
NVD
5.5 medium
Expand this section
SUSE
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-IMAGEMAGICK-3023952
  • published 15 Sep 2022
  • disclosed 27 Aug 2022
  • credit Unknown

How to fix?

Upgrade ImageMagick to version 6.9.12-62, 7.1.0-47 or higher.

Overview

ImageMagick is a pod that allows you to convert, edit and compose Images.

Affected versions of this package are vulnerable to Buffer Overflow while processing a malformed TIFF file.