Memory Leak Vulnerability Affecting imagemagick package, versions >=6.8.8-9


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high
Expand this section
RHEL
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-IMAGEMAGICK-470835
  • published 2 Oct 2019
  • disclosed 18 Jul 2017
  • credit Unknown

How to fix?

There is no fixed version for ImageMagick.

Overview

ImageMagick is a pod that allows you to convert, edit and compose Images.

Affected versions of this package are vulnerable to Memory Leak Vulnerability. ImageMagick is vulnerable to memory leaks. The WritePCXImage() function in coders/pcx.c does not properly handle the memory, leading to memory leaks that can crash the application.