Improper Input Validation Affecting imagemagick package, versions >=0.0.0


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High
Expand this section
NVD
5.5 medium
RHEL  medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-IMAGEMAGICK-470950
  • published 2 Oct 2019
  • disclosed 20 Nov 2014
  • credit Unknown

How to fix?

There is no fixed version for ImageMagick.

Overview

ImageMagick is a pod that allows you to convert, edit and compose Images.

Affected versions of this package are vulnerable to Improper Input Validation. ImageMagick is susceptible to denial of service (DoS) attacks. The vulnerability is due to file descriptor consumption.