Improper Input Validation Affecting imagemagick package, versions >=0.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 7.8% (94th percentile)
Expand this section
NVD
7.5 high
Expand this section
Red Hat
5.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-IMAGEMAGICK-471005
  • published 2 Oct 2019
  • disclosed 7 Jan 2016
  • credit Unknown

How to fix?

There is no fixed version for ImageMagick.

Overview

ImageMagick is a pod that allows you to convert, edit and compose Images.

Affected versions of this package are vulnerable to Improper Input Validation. ImageMagick is vulnerable to denial of service (DoS) attacks. AcquireVirtualMemory has a memory leak which is triggered when AcquireMagickResource starts returning false.