Improper Input Validation Affecting imagemagick package, versions >=0.0.0


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High

    Threat Intelligence

    EPSS 0.43% (74th percentile)
Expand this section
NVD
6.5 medium
Expand this section
Red Hat
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-IMAGEMAGICK-471217
  • published 2 Oct 2019
  • disclosed 24 Jul 2017
  • credit Unknown

How to fix?

There is no fixed version for ImageMagick.

Overview

ImageMagick is a pod that allows you to convert, edit and compose Images.

Affected versions of this package are vulnerable to Improper Input Validation. ImageMagick is vulnerable to denial of service (DoS). The vulnerability is possible because coders/mat.c is missing validation, leading to an assertion failure in the DestroyImage() function in MagickCore/image.c,