Out-of-Bounds Affecting libopus package, versions >=0.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.16% (52nd percentile)
Expand this section
NVD
7.8 high
Expand this section
Red Hat
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-LIBOPUS-470657
  • published 13 Nov 2019
  • disclosed 28 Jul 2016
  • credit Unknown

How to fix?

There is no fixed version for libopus.

Overview

libopus is a CocoaPods package for Opus

Affected versions of this package are vulnerable to Out-of-Bounds. The vulnerability exists because silk/NLSF_stabilize.c does not properly validate the negative input when computing a minimum distance.