Double Free Affecting libwebp package, versions >=0.4.2, <1.3.1


Severity

Recommended
0.0
high
0
10

CVSS assessment made by Snyk's Security Team

    Threat Intelligence

    EPSS
    0.11% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-LIBWEBP-5489511
  • published 30 Apr 2023
  • disclosed 11 Apr 2023
  • credit Irvan Kurniawan

How to fix?

Upgrade libwebp to version 1.3.1 or higher.

Overview

libwebp is a Library to encode and decode images in WebP format.

Affected versions of this package are vulnerable to Double Free which can lead to memory corruption and a potentially exploitable crash.

CVSS Scores

version 3.1
Expand this section

Snyk

7.5 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    High
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    Required
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    High
  • Availability (A)
    High
Expand this section

NVD

7.5 high
Expand this section

SUSE

7.5 high
Expand this section

Red Hat

7.5 high