Use of a Broken or Risky Cryptographic Algorithm Affecting mbedtls package, versions <2.16.11 >=2.17.0, <2.27.0


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High

    Threat Intelligence

    EPSS 0.05% (19th percentile)
Expand this section
NVD
4.7 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-MBEDTLS-3244955
  • published 23 Jan 2023
  • disclosed 23 Jan 2023
  • credit Zili Kou, Wenjian He, Sharad Sinha, and Wei Zhang

How to fix?

Upgrade mbedTLS to version 2.16.11, 2.27.0 or higher.

Overview

mbedTLS is an An open source, portable, easy to use, readable and flexible SSL library.

Affected versions of this package are vulnerable to Use of a Broken or Risky Cryptographic Algorithm in the function mbedtls_mpi_exp_mod() in lignum.c, which allows attackers with access to precise enough timing and memory access information (typically an untrusted operating system attacking a secure enclave such as SGX or the TrustZone secure world) to recover the private keys used in RSA.

References