Out-of-Bounds Affecting mupdf package, versions >=1.9, <1.10


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
7.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-MUPDF-470639
  • published 2 Oct 2019
  • disclosed 15 May 2017
  • credit Unknown

How to fix?

Upgrade MuPDF to version 1.10 or higher.

Overview

MuPDF is a lightweight PDF and XPS viewer.

Affected versions of this package are vulnerable to Out-of-Bounds. MuPDF is vulnerable to memory corruption and possible code execution through the JBIG2 parser. It is possible for attackers to pass a PDF to a user to cause the application to pass memset a negative number. This flaw causes memory corruption and potentially code execution as well.