Out-of-Bounds Affecting mupdf package, versions >=1.7, <1.10


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-MUPDF-470704

  • published

    2 Oct 2019

  • disclosed

    27 Jul 2016

  • credit

    Unknown

How to fix?

Upgrade MuPDF to version 1.10 or higher.

Overview

MuPDF is a lightweight PDF and XPS viewer.

Affected versions of this package are vulnerable to Out-of-Bounds. MuPDF is vulnerable to denial of service (DoS) attacks that could possibly lead to arbitrary code execution. These attacks are possible because there is a heap-based buffer overflow in the pdf_load_mesh_params function.