Use After Free Affecting mupdf package, versions >=1.7, <1.10


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-MUPDF-471142

  • published

    2 Oct 2019

  • disclosed

    21 Jul 2016

  • credit

    Unknown

How to fix?

Upgrade MuPDF to version 1.10 or higher.

Overview

MuPDF is a lightweight PDF and XPS viewer.

Affected versions of this package are vulnerable to Use After Free. MuPDF is vulnerable to a use-after-free vulnerability. This vulnerability is located in the pdf_load_xref function and allows remote attackers to perform denial of service (DoS) attacks using a PDF file.