Out-of-Bounds Affecting opencv package, versions >=0.0.0, <3.3.1


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
RHEL
3.3 low
Expand this section
NVD
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENCV-470847
  • published 2 Oct 2019
  • disclosed 14 Aug 2017
  • credit Unknown

How to fix?

Upgrade OpenCV to version 3.3.1 or higher.

Overview

OpenCV is an OpenCV (Computer Vision) for iOS

Affected versions of this package are vulnerable to Out-of-Bounds. OpenCV is vulnerable to copy buffer overflows. If the length of AutoBuffer _src in modules/imgcodecs/src/grfmt_pxm.cpp is smaller than expected, it will cause a copy buffer overflow further down the line. Using this flaw, attackers can trigger remote code execution (RCE) attacks or denial of service (DoS) attacks.