Integer Overflow or Wraparound Affecting opencv package, versions >=0.0.0, <3.3.1


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.8 high
Expand this section
RHEL
7 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENCV-470868
  • published 2 Oct 2019
  • disclosed 27 Sep 2017
  • credit Unknown

How to fix?

Upgrade OpenCV to version 3.3.1 or higher.

Overview

OpenCV is an OpenCV (Computer Vision) for iOS

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. OpenCV is vulnerable to denial of service (DoS) attacks. These attacks are possible because the FillUniColor function and the FillUniGray function don't check for the length of the input, causing an integer overflow.