Integer Overflow or Wraparound Affecting opencv Open this link in a new tab package, versions >=0.0.0, <3.3.1


0.0
high
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENCV-470885

  • published

    2 Oct 2019

  • disclosed

    14 Aug 2017

  • credit

    Unknown

How to fix?

Upgrade OpenCV to version 3.3.1 or higher.

Overview

OpenCV is an OpenCV (Computer Vision) for iOS

Affected versions of this package are vulnerable to Integer Overflow or Wraparound. OpenCV is vulnerable to integer overflows. The PxMDecoder::readData has a flaw which allows attackers to cause an integer overflow when calculating src_pitch. Using this flaw, attackers can launch remote code execution (RCE) attacks and denial of service (DoS) attacks.