Out-of-bounds Write Affecting opencv package, versions >=2.4.10, <3.3.1


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENCV-470927

  • published

    2 Oct 2019

  • disclosed

    23 Aug 2017

  • credit

    Unknown

How to fix?

Upgrade OpenCV to version 3.3.1 or higher.

Overview

OpenCV is an OpenCV (Computer Vision) for iOS

Affected versions of this package are vulnerable to Out-of-bounds Write. OpenCV is vulnerable to out-of-bounds write. An incomplete fix of CVE-2017-12597 causes the out-of-bounds write when cv::imread is used to input an image into the FillColorRow1() function in utils.cpp, leading to a segmentation fault. Using this flaw, attackers can trigger remote code execution (RCE) attacks or denial of service (DoS) attacks.