Out-of-Bounds Affecting opencv Open this link in a new tab package, versions >=3.3.1, <3.4.1


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENCV-471192

  • published

    2 Oct 2019

  • disclosed

    7 Jan 2018

  • credit

    Unknown

How to fix?

Upgrade OpenCV to version 3.4.1 or higher.

Overview

OpenCV is an OpenCV (Computer Vision) for iOS

Affected versions of this package are vulnerable to Out-of-Bounds. OpenCV is vulnerable to heap buffer overflow attacks. The vulnerability exists in the function cv::Jpeg2KDecoder::readComponent8u and can happen when malformed data is being read.