Improper Input Validation Affecting opencv package, versions >=3.3.1, <3.4.1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High

    Threat Intelligence

    EPSS 0.09% (35th percentile)
Expand this section
NVD
5.5 medium
Expand this section
Red Hat
3.3 low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENCV-471275
  • published 2 Oct 2019
  • disclosed 7 Jan 2018
  • credit Unknown

How to fix?

Upgrade OpenCV to version 3.4.1 or higher.

Overview

OpenCV is an OpenCV (Computer Vision) for iOS

Affected versions of this package are vulnerable to Improper Input Validation. OpenCV is vulnerable to denial of service (DoS) through assertion failures. The vulnerability exists due to an incorrect integer cast which causes an assertion failure in cv::RBaseStream::setPost