Out-of-Bounds Affecting openssl package, versions >=1.0.200, <1.0.207


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470644

  • published

    2 Oct 2019

  • disclosed

    29 Feb 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.207 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-Bounds openssl is vulnerable to denial of service (DoS) attacks. The library improperly calculates string lengths, allowing a malicious user to cause a denial of service by passing a large string to the system.

References