Out-of-Bounds Affecting openssl package, versions >=1.0.1, <1.0.200


0.0
critical

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical
Expand this section
RHEL
5.6 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENSSL-470651
  • published 2 Oct 2019
  • disclosed 16 Apr 2016
  • credit Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-Bounds. OpenSSL is vulnerable to arbitrary code execution or denial of service attacks. Due to a flaw, an attacker can use a certificate which leads to a crash or execution of arbitrary code upon verification or re-encoding of certificate by OpenSSL.

References