Resource Management Errors Affecting openssl Open this link in a new tab package, versions >=1.0.1, <1.0.200 >=1.0.204.1, <1.0.207


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470682

  • published

    2 Oct 2019

  • disclosed

    1 Mar 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200, 1.0.207 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Resource Management Errors. OpenSSL is vulnerable to denial of service (DoS) attacks. A malicious user can cause a memory leak by seeking to connect to the system with an invalid username. By opening multiple invalid connections this way, the malicious user can cause the system to run out of memory.