Out-of-Bounds Affecting openssl Open this link in a new tab package, versions >=1.0.1, <1.0.109


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470746

  • published

    2 Oct 2019

  • disclosed

    3 May 2014

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.109 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-Bounds. OpenSSL is vulnerable to denial of service (DoS) attacks. These attacks are possible due to multiple buffer overflows in crypto/srp/srp_lib.c. The buffer overflows can be triggered by an invalid SRP g, A or B parameter.