Out-of-bounds Write Affecting openssl package, versions >=1.0.1, <1.0.200 >=1.0.204.1, <1.0.209


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470751

  • published

    2 Oct 2019

  • disclosed

    16 Sep 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200, 1.0.209 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-bounds Write. OpenSSL is vulnerable to denial of service (DoS) attacks. The library does not validate division results, allowing a malicious user to cause a denial of service via an out-of-bounds write by sending a overly large BIGNUM.