Out-of-bounds Write Affecting openssl Open this link in a new tab package, versions >=1.0.1, <1.0.200 >=1.0.204.1, <1.0.209


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470753

  • published

    2 Oct 2019

  • disclosed

    26 Jul 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200, 1.0.209 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-bounds Write. OpenSSL is vulnerable to Denial Of Service (DoS) attacks. A malicious user can cause an integer overflow via the MDC2_Update function which can lead to an integer overflow. A malicious user can make use of this to cause a heap corruption or a denial of service.