Out-of-Bounds Affecting openssl Open this link in a new tab package, versions >=1.0.0, <1.0.108


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470754

  • published

    2 Oct 2019

  • disclosed

    4 Apr 2012

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.108 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-Bounds. OpenSSL is vulnerable to denial of service (DoS) attacks and possible other attacks. These attacks are possible because the asn1_d2i_read_bio function doesn't correctly interpret integer data which can be leveraged to do buffer overflow attacks or cause memory consumption.