Out-of-Bounds Affecting openssl package, versions >=1.0.0, <1.0.108


0.0
high
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470764

  • published

    2 Oct 2019

  • disclosed

    23 Sep 2011

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.108 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-Bounds. OpenSSL is vulnerable to denial of service (DoS) attacks and possibly other attacks. These attacks are possible because of an integer underflow in the EVP_DecodeUpdate function. The use of base64 data can trigger this buffer overflow which can cause memory corruption.