Improper Input Validation Affecting openssl package, versions >=1.0.0, <1.0.110


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Availability High

    Threat Intelligence

    EPSS 94.67% (100th percentile)
Expand this section
NVD
6.5 medium
Expand this section
Red Hat
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENSSL-470813
  • published 2 Oct 2019
  • disclosed 15 Oct 2014
  • credit Unknown

How to fix?

Upgrade OpenSSL to version 1.0.110 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Improper Input Validation. OpenSSL is vulnerable to denial of service (DoS) attacks. These attacks are possible because there is a memory leak in the tls_decrypt_ticket function which can be triggered through a session ticket.

References