Race Condition Affecting openssl Open this link in a new tab package, versions >=1.0.200, <1.0.202


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470891

  • published

    2 Oct 2019

  • disclosed

    11 Jun 2015

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.202 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Race Condition. OpenSSL is vulnerable to denial of service (DoS) attacks and possibly other attacks. A malicious user can pass a reused session ticket to the system that can cause a double free that can lead to the system crashing.

References