Numeric Errors Affecting openssl Open this link in a new tab package, versions >=1.0.0, <1.0.1

  • Attack Complexity


  • User Interaction


Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id


  • published

    2 Oct 2019

  • disclosed

    19 Apr 2012

  • credit


How to fix?

Upgrade OpenSSL to version 1.0.1 or higher.


OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Numeric Errors. OpenSSL is vulnerable to denial of service (DoS) attacks and possibly other attacks. These attacks are possible because there is an integer underflow when TLS 1.1, TLS 1.2 or DTLS is used with CBC encryption.