Key Management Errors Affecting openssl Open this link in a new tab package, versions >=1.0.200, <1.0.211 >=1.0.204.1, <1.0.205


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470936

  • published

    2 Oct 2019

  • disclosed

    12 Jun 2018

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.211, 1.0.205 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Key Management Errors openssl is vulnerable to denial of service (DoS) attacks. A malicious user can pass a large prime number during a TLS handshake that can cause the client to take a long time generating a key for this, leading to the client hanging and possibly crashing.