Code Affecting openssl package, versions >=1.0.200


0.0
medium

Snyk CVSS

    Attack Complexity Low
NVD  medium
RHEL  low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-COCOAPODS-OPENSSL-470960
  • published 2 Oct 2019
  • disclosed 18 Nov 2014
  • credit Unknown

How to fix?

There is no fixed version for OpenSSL.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Code. OpenSSL is vulnerable to denial of service (DoS) attacks. These attacks are possible because AES NI support on 64-bit x86 platforms doesn't properly handle non-blocking I/O cases. This flaw causes pointer corruption and application crashes.