Improper Input Validation Affecting openssl package, versions >=1.0.200, <1.0.209 >=1.0.204.1, <1.0.209


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470967

  • published

    2 Oct 2019

  • disclosed

    26 Jul 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.209, 1.0.209 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Improper Input Validation. OpenSSL is vulnerable to Denial of Service (DoS) attacks. A malicious user can crash the server by passing a malformed SHA512 TLS session ticket HMAC to the server, resulting in an out-of-bounds read which ultimately will result in crashing the server.