Numeric Errors Affecting openssl Open this link in a new tab package, versions >=1.0.1, <1.0.200 >=1.0.204.1, <1.0.208


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-COCOAPODS-OPENSSL-470990

  • published

    2 Oct 2019

  • disclosed

    3 May 2016

  • credit

    Unknown

How to fix?

Upgrade OpenSSL to version 1.0.200, 1.0.208 or higher.

Overview

OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Numeric Errors. OpenSSL is vulnerable to buffer overflows. A malicious user can pass large amounts of input data to the EVP_EncodeUpdate function, which can cause a buffer overflow in the length check, allowing the malicious user to cause heap corruption.