Out-of-Bounds Affecting openssl package, versions >=1.0.200, <1.0.207 >=, <1.0.207



    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 76.9% (99th percentile)
Expand this section
9.8 critical
Expand this section
Red Hat
5.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • published 2 Oct 2019
  • disclosed 3 Mar 2016
  • credit Unknown

How to fix?

Upgrade OpenSSL to version 1.0.207, 1.0.207 or higher.


OpenSSL is a SSL/TLS and Crypto toolkit. Deprecated in Mac OS and gone in iOS, this spec gives your project non-deprecated OpenSSL support.

Affected versions of this package are vulnerable to Out-of-Bounds. OpenSSL is vulnerable to to Denial of Service (DoS) attacks. The doapr_outch function in crypto/bio/b_print.c in OpenSSL 1.0.1 before 1.0.1s and 1.0.2 before 1.0.2g, found in the affected versions of OpenSSL, does not verify that certain memory allocations succeed, allowing a malicious user to cause a denial of service by passing a large string to the server, crashing it due to the server running out of memory.